<!doctype html>
<html lang="en-US" class="no-js">
<head>
    <meta charset="UTF-8">
    <meta name="format-detection" content="telephone=no">
    <link rel="pingback" href="http://discoposse.com/xmlrpc.php">
    <link rel="icon" type="image/x-icon" href="http://cdn.discoposse.com/wp-content/uploads/2016/03/favicon.png">    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no">
    <title>Why your Security Products are Inherently Insecure &#8211; DiscoPosse.com</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="DiscoPosse.com &raquo; Feed" href="http://discoposse.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="DiscoPosse.com &raquo; Comments Feed" href="http://discoposse.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="DiscoPosse.com &raquo; Why your Security Products are Inherently Insecure Comments Feed" href="http://discoposse.com/2017/04/09/why-your-security-products-are-inherently-insecure/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/discoposse.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bootstrap-css'  href='http://cdn.discoposse.com/wp-content/plugins/easy-bootstrap-shortcodes/styles/bootstrap.min.css.gzip?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-fa-icon-css'  href='http://cdn.discoposse.com/wp-content/plugins/easy-bootstrap-shortcodes/styles/font-awesome.min.css.gzip?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://cdn.discoposse.com/wp-content/plugins/contact-form-7/includes/css/styles.css.gzip?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='pc_google_analytics-frontend-css'  href='http://cdn.discoposse.com/wp-content/plugins/pc-google-analytics/assets/css/frontend.css.gzip?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='pdfprnt_stylesheet-css'  href='http://cdn.discoposse.com/wp-content/plugins/pdf-print/css/style.css.gzip?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='pi-fontawesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.min.css?ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='pi-googlefont-css'  href='//fonts.googleapis.com/css?family=Lato%3A%3A400%2C400italic%7CDroid+Serif%3A400%2C700&#038;ver=4.3' type='text/css' media='all' />
<link rel='stylesheet' id='pi-justifiedGallery-css'  href='http://cdn.discoposse.com/wp-content/themes/titan/css/lib/justifiedGallery.min.css.gzip?ver=3.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='pi-magnific-css'  href='http://cdn.discoposse.com/wp-content/themes/titan/css/lib/magnific-popup.css.gzip?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='pi-owlcarousel-css'  href='http://cdn.discoposse.com/wp-content/themes/titan/css/lib/owl.carousel.css.gzip?ver=1.18' type='text/css' media='all' />
<link rel='stylesheet' id='pi-main-css'  href='http://cdn.discoposse.com/wp-content/themes/titan/css/style.css.gzip?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='pi-titan-css'  href='http://cdn.discoposse.com/wp-content/themes/titan/style.css.gzip?ver=1.0' type='text/css' media='all' />
<style id='pi-titan-inline-css' type='text/css'>
h1{ font-family: "Open Sans";}
h2{ font-family: "Open Sans";}
h3{ font-family: "Open Sans";}
h4{ font-family: "Open Sans";}
h6{ font-family: "Open Sans";}
p{ font-family: "Open Sans";}

</style>
<link rel='stylesheet' id='pi_yourgooglefont-css'  href='https://fonts.googleapis.com/css?family=Open+Sans&#038;ver=1.0' type='text/css' media='' />
<link rel='stylesheet' id='pi_custom_color-css'  href='http://cdn.discoposse.com/wp-content/themes/titan/css/colors/yellow.css.gzip?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='github-profile-octicons-css'  href='http://cdn.discoposse.com/wp-content/plugins/github-profile-widget/css/octicons/octicons.css.gzip?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='ebs_dynamic_css-css'  href='http://discoposse.com/wp-content/plugins/easy-bootstrap-shortcodes/styles/ebs_dynamic_css.php?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://cdn.discoposse.com/wp-content/plugins/jetpack/css/jetpack.css.gzip?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='event-list-css'  href='http://cdn.discoposse.com/wp-content/plugins/event-list/includes/css/event-list.css.gzip?ver=4.7.3' type='text/css' media='all' />
<script type='text/javascript' src='http://cdn.discoposse.com/wp-includes/js/jquery/jquery.js.gzip?ver=1.12.4'></script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-includes/js/jquery/jquery-migrate.min.js.gzip?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js.gzip?ver=20150408'></script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/plugins/easy-bootstrap-shortcodes/js/bootstrap.min.js.gzip?ver=4.7.3'></script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/plugins/pc-google-analytics/assets/js/frontend.min.js.gzip?ver=1.0.0'></script>
<!-- This site uses the Better Analytics plugin.  https://marketplace.digitalpoint.com/better-analytics.3354/item -->
<script type='text/javascript' src='http://discoposse.com/wp-content/plugins/better-analytics/js/loader.php?ver=1.2.1.js' ></script><link rel='https://api.w.org/' href='http://discoposse.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://discoposse.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://cdn.discoposse.com/wp-includes/wlwmanifest.xml.gzip" /> 
<link rel='prev' title='One Vault to Secure Them All:  HashiCorp Releases Vault Enterprise 0.7' href='http://discoposse.com/2017/03/21/one-vault-to-secure-them-all-hashicorp-releases-vault-enterprise-0-7/' />
<meta name="generator" content="WordPress 4.7.3" />
<link rel="canonical" href="http://discoposse.com/2017/04/09/why-your-security-products-are-inherently-insecure/" />
<link rel='shortlink' href='http://wp.me/p6P9j6-1F5' />
<link rel="alternate" type="application/json+oembed" href="http://discoposse.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdiscoposse.com%2F2017%2F04%2F09%2Fwhy-your-security-products-are-inherently-insecure%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://discoposse.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdiscoposse.com%2F2017%2F04%2F09%2Fwhy-your-security-products-are-inherently-insecure%2F&#038;format=xml" />
	<script>
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
		
		ga('create', 'UA-22628890-1', 'auto');
		ga('send', 'pageview');
		
		</script>

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style>    <script type="text/javascript">
        window.PI_OB  = {};
        PI_OB.ajaxurl = "http://discoposse.com/wp-admin/admin-ajax.php";
        PI_OB.imageuri = "http://discoposse.com/wp-content/themes/titan/images/";
    </script>
    <link rel="icon" type="image/x-icon" href="http://cdn.discoposse.com/wp-content/uploads/2016/03/favicon.png"><style type="text/css">
.header-logo{
padding-top: 0px;
padding-bottom: 0px;
}</style>
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style>
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Why your Security Products are Inherently Insecure" />
<meta property="og:url" content="http://discoposse.com/2017/04/09/why-your-security-products-are-inherently-insecure/" />
<meta property="og:description" content="You&#8217;re being sold snake oil every day in the world of IT. It is about time that we just lay this out honestly. The products that you are buying are not solutions. They are methodologies. Why …" />
<meta property="article:published_time" content="2017-04-09T20:02:18+00:00" />
<meta property="article:modified_time" content="2017-04-09T20:02:18+00:00" />
<meta property="og:site_name" content="DiscoPosse.com" />
<meta property="og:image" content="https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security.png" />
<meta property="og:image:width" content="1780" />
<meta property="og:image:height" content="724" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@discoposse" />
<meta name="twitter:image" content="https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@discoposse" />
			<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/			</style>
		</head>
<body class="post-template-default single single-post postid-6391 single-format-standard">

    
    <div id="wrapper">
                <!-- Header -->
        <header id="pi-header" class="">
            <!-- Logo -->
            <div class="header-logo text-center"><a class="pi-logo logo" href="http://discoposse.com/"><img src="http://cdn.discoposse.com/wp-content/uploads/2016/08/discoposse-header-2016.png" alt="DiscoPosse.com"></a></div>            <!-- / Logo -->
            
            <div class="header-top">
                <div class="pi-header-fixed">
                    <div class="pi-container">
                                                    <!-- Toggle menu -->
                            <div class="toggle-menu">
                                <span class="item item-1"></span>
                                <span class="item item-2"></span>
                                <span class="item item-3"></span>
                            </div>
                            <!-- / Toggle menu -->
                            <nav class="pi-navigation"><ul id="pi_menu" class="pi-menulist"><li id="menu-item-5255" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5255"><a href="http://discoposse.com/podcast/">Podcast</a></li>
<li id="menu-item-6125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6125"><a href="http://discoposse.com/vdm30in30/">#vDM30in30</a></li>
<li id="menu-item-5729" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-5729"><a href="http://discoposse.com/#">Archive Blogs by Category</a>
<ul class="sub-menu">
	<li id="menu-item-5722" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5722"><a href="http://discoposse.com/category/cloud-virt/">Cloud, Virtualization and Architecture</a></li>
	<li id="menu-item-5720" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5720"><a href="http://discoposse.com/category/apps-os-databases/">Applications, OS and Databases</a></li>
	<li id="menu-item-5721" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5721"><a href="http://discoposse.com/category/automation-development/">Automation, Scripting and Development</a></li>
	<li id="menu-item-5723" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5723"><a href="http://discoposse.com/category/community/">Community and Thought Leadership</a></li>
	<li id="menu-item-5728" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5728"><a href="http://discoposse.com/category/training-courses/">Training</a></li>
	<li id="menu-item-5726" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5726"><a href="http://discoposse.com/category/networking-security/">Networking and Security</a></li>
	<li id="menu-item-4813" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4813"><a href="http://discoposse.com/category/bcp-dr/">BCP/DR</a></li>
	<li id="menu-item-5727" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5727"><a href="http://discoposse.com/category/reviews/">Reviews</a></li>
</ul>
</li>
<li id="menu-item-5447" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5447"><a target="_blank" href="http://virtualdesignmaster.io">Virtual Design Master</a></li>
<li id="menu-item-5884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5884"><a href="http://discoposse.com/vfit/">#vFit</a></li>
<li id="menu-item-4834" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-4834"><a href="http://discoposse.com/about/">About me and DiscoPosse</a>
<ul class="sub-menu">
	<li id="menu-item-5256" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5256"><a href="http://discoposse.com/events/">Events</a></li>
	<li id="menu-item-4831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4831"><a href="http://discoposse.com/media-and-print/">Media and Print</a></li>
	<li id="menu-item-4825" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4825"><a href="http://www.discoposse.com/">Other Goodies</a>
	<ul class="sub-menu">
		<li id="menu-item-4821" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4821"><a href="http://discoposse.com/category/music-and-media/">Music and Media</a></li>
		<li id="menu-item-4820" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4820"><a href="http://discoposse.com/category/fitness/">Fitness and Food</a></li>
		<li id="menu-item-5730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5730"><a href="http://discoposse.com/category/podcast/">Podcast</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-6388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6388"><a href="#">Sponsors</a>
<ul class="sub-menu">
	<li id="menu-item-6387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6387"><a href="http://discoposse.com/sponsor-vembu/">Sponsor-Vembu</a></li>
</ul>
</li>
</ul></nav>                        <div class="header-right">
                            <div class="pi-social"><a href="https://twitter.com/DiscoPosse" target="_blank"><i class="fa fa-twitter"></i></a><a href="http://www.youtube.com/DiscoPosse" target="_blank"><i class="fa fa-youtube-play"></i></a></div>    <div class="toggle-search item">
        <i class="fa fa-search"></i>
    </div>
        <!-- Page search -->
        <div class="page-search">
            <div class="tb">
                <span class="page-search-close">&times;</span>
                <div class="tb-cell">
                    <form action="http://discoposse.com/" method="get" >
                        <input name="s" type="search" value="Search and hit enter" />
                    </form>
                </div>
            </div>
        </div>
        <!-- / Page search -->
                                </div>
                    </div>
                </div>
            </div>
        </header>
        <!-- / Header -->

            <section class="main-content pi-single">
        <div class="pi-container">
            <div class="pi-row">
                <div class="pi-content">
                                      <article class="post-6391 post type-post status-publish format-standard has-post-thumbnail hentry category-cloud-virt tag-insecure tag-security tag-tdi tag-test-driven-infrastructure tag-vulnerability">
                        <!--Post media-->
                        <div class="post-media"><div class="images"><img width="960" height="390" src="https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security-960x390.png" class="attachment-pi-standard size-pi-standard wp-post-image" alt="" srcset="https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security-960x390.png 960w, https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security-300x122.png 300w, https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security-768x312.png 768w, https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security-1024x417.png 1024w, https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security-1200x488.png 1200w, https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security-415x169.png 415w" sizes="(max-width: 960px) 100vw, 960px" data-attachment-id="6392" data-permalink="http://discoposse.com/2017/04/09/why-your-security-products-are-inherently-insecure/false-security/" data-orig-file="https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security.png" data-orig-size="1780,724" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="false-security" data-image-description="" data-medium-file="https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security-300x122.png" data-large-file="https://cdn.discoposse.com/wp-content/uploads/2017/04/09155922/false-security-1024x417.png" /></div><div class="post-date"><span class="day">09 </span><span class="month"> Apr </span><span class="year"> 2017</span></div></div>                        <!--End/Post media-->
                        <div class="post-header">
                            <div class="post-cat">
                               <ul><li><a href='http://discoposse.com/category/cloud-virt/'>Cloud, Virtualization and Architecture</a></li></ul>                            </div>

                            <div class="post-title text-uppercase">
                                <h2>Why your Security Products are Inherently Insecure</h2>
                            </div>

                            <div class="post-meta">
                                By <a href="http://discoposse.com/author/discoposse/">DiscoPosse</a>
        / No Comment                            </div>
                            <div class="pi-border">
                                <span></span>
                                <span></span>
                            </div>
                        </div> 

                        <div class="post-body">
                            <div class="post-entry">
                              <div class="pdfprnt-top-right"><a href="http://discoposse.com/2017/04/09/why-your-security-products-are-inherently-insecure/?print=pdf" class="pdfprnt-button pdfprnt-button-pdf" target="_blank"><img src="http://cdn.discoposse.com/wp-content/plugins/pdf-print/images/pdf.png" alt="image_pdf" title="View PDF" /></a><a href="http://discoposse.com/2017/04/09/why-your-security-products-are-inherently-insecure/?print=print" class="pdfprnt-button pdfprnt-button-print" target="_blank"><img src="http://cdn.discoposse.com/wp-content/plugins/pdf-print/images/print.gif" alt="image_print" title="Print Content" /></a></div><p>You&#8217;re being sold snake oil every day in the world of IT. It is about time that we just lay this out honestly. The products that you are buying are not solutions. They are methodologies. Why does this semantic difference matter? It matters because we are blindly putting tools into place under the assumption that they are a solution to a problem. The truth is that they are merely tools in the fight to solve the problem.</p>
<h3>Conceptual &#8211; Logical &#8211; Physical</h3>
<p>Go back to the basics of systems architecture and infrastructure design for a moment. We view things in three stages of the design process as conceptual, logical, and physical. Conceptual design is thinking at a high level on the goal such as &#8220;the application servers will be protected from intrusion&#8221;. Moving to the logical physical version to expand on that concept would be something like &#8220;Layer 4-7 firewalls will be deployed at the ingress and egress point for the application servers&#8221;. Getting down to the physical is something like &#8220;Product X will be deployed to provide layer 4-7 firewall protection&#8221; which is the result of designing to meet the first two requirements.</p>
<p>The issue that we face as an industry is two-fold. First, we often start at &#8220;Product X will be deployed&#8221; without having done the due diligence on what the actual business and technical requirements are which need to be solved. The second issue is that we buy Product X, deploy Product X, and then everyone goes for a project completion dinner and celebrates that we have finished up the deployment with the bold assumption that we are inherently secure.</p>
<p>Many organizations are buying products or embracing some new technologies into their environments based on a promise. Promises should always bear translated to assumptions. I&#8217;ll start with one that I am seeing a lot of lately which is this:</p>
<blockquote><p>&#8220;Containers are more secure for applications than virtual machines&#8221;</p></blockquote>
<p>This is both true and false at the same time. The wording is important. What the phrase should say is &#8220;containers have the ability to be architected and deployed to be more secure for applications than traditional virtual machines&#8221;.</p>
<p>Here&#8217;s why phrasing is important.</p>
<h3>Why is your security product inherently insecure?</h3>
<p>You can&#8217;t buy a bow and arrow and suddenly you are an archer. The same goes for security. Just because you have bought a security product, it does not mean that you are secure. It&#8217;s actually the polar opposite. Your environment is inherently insecure. Even if you are absolutely sure that you are deployed in the most secure manner possible, you should ALWAYS ASSUME that you have been breached.</p>
<p>What&#8217;s the solution for this? This comes in three forms:</p>
<ol>
<li>Accept that you are insecure and build processes around that assumption</li>
<li>Deploy and continuously test your security platforms</li>
<li>Engage third-party testers and products to ensure continuous objective testing</li>
</ol>
<p>Let&#8217;s dive into these three areas a little bit further.</p>
<h4>Accept that you are insecure and build processes around that assumption</h4>
<p>Point 1 is the key to begin with. Assume you have been breached. Now what? How are you aggregating your logs? How are you protecting the logging both locally on the application endpoints as well as in your central logging environments? If you have to assume that your ingress has been compromised, you also have to assume that your log environments have been compromised as well. You need local protection on each system plus centralized, read-only aggregation with regular snapshots of that environment to ensure its integrity too.</p>
<p>The build process you use will inevitably call on some external dependencies. It could be patches, software updates, or any of a wide variety of files and applications. Assume that these are inaccessible or compromised as you define your programmatic build process to use locally cached data and application dependencies as much as possible. And yes, the programmatic build process is key to ensuring consistency and security. You should include checksum and signature detection for all source files as you put them into the virtual application instances.</p>
<h4>Deploy and continuously test your security platforms</h4>
<p><a href="https://cdn.discoposse.com/wp-content/uploads/2017/04/09160046/falsesensesecurity.jpg"><img data-attachment-id="6393" data-permalink="http://discoposse.com/2017/04/09/why-your-security-products-are-inherently-insecure/falsesensesecurity/" data-orig-file="https://cdn.discoposse.com/wp-content/uploads/2017/04/09160046/falsesensesecurity.jpg" data-orig-size="492,366" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="falsesensesecurity" data-image-description="" data-medium-file="https://cdn.discoposse.com/wp-content/uploads/2017/04/09160046/falsesensesecurity-300x223.jpg" data-large-file="https://cdn.discoposse.com/wp-content/uploads/2017/04/09160046/falsesensesecurity.jpg" class="alignright size-full wp-image-6393" src="https://cdn.discoposse.com/wp-content/uploads/2017/04/09160046/falsesensesecurity.jpg" alt="" width="492" height="366" srcset="https://cdn.discoposse.com/wp-content/uploads/2017/04/09160046/falsesensesecurity.jpg 492w, https://cdn.discoposse.com/wp-content/uploads/2017/04/09160046/falsesensesecurity-300x223.jpg 300w, https://cdn.discoposse.com/wp-content/uploads/2017/04/09160046/falsesensesecurity-415x309.jpg 415w" sizes="(max-width: 492px) 100vw, 492px" /></a>Test-driven development is a great methodology. I have long been a user and a<a href="http://discoposse.com/2012/06/02/tdi-using-test-driven-development-methodologies-for-infrastructure/"> proponent of what is known as test-driven infrastructure </a>and this includes the need for security as a part of the cycle. The only way that you know your detection system is working is if you test it when there is an issue. Assuming detection without truly testing the response means that you are relying on the assumption. Your CISO does not rely on assumptions, and neither do your customers.</p>
<p>Whichever products you embrace in your IT security portfolio, they will inevitably come with some form of baked in testing procedures and processes. Be aggressive and adamant with your vendors that this is a requirement for you. Nobody wants to be caught going back after a vulnerability to have to find out that it was detectable and preventable.</p>
<h4>Engage third-party testers and products to ensure continuous objective testing</h4>
<p>I hire someone to do my taxes. Yes, I can do them myself. That doesn&#8217;t mean that I&#8217;m an expert and can find every advantage within the tax code to get the best results. Why would I treat security and vulnerability testing any differently than any other discipline in my business and IT organization. Using 3rd party companies will give you the ability to lean on them for expertise, and most importantly, certification and validation of your security stance in an active environment.</p>
<p>Having spent years in financial services environments which have stringent requirements around auditing and security, I can tell you that no matter how secure even the IT security team thought they were, a 3rd party can come in and teach some rough lessons in a couple of hours.</p>
<h3>Turn Assumptions into Actions</h3>
<p>Going back to the example that containers are more secure than virtual machines gives us a great one to work from. Containers typically run thinner and provide a smaller attack surface for vulnerabilities, malware, and other attacks by bad actors. No, not Lorenzo Lamas, but anyone who is attempting to breach your environment. We will usually hear them being referred to as bad actors.</p>
<p>The truth is that containers as a construct, are solving deployment challenges first. Security is a secondary win that implies you have the practices in place to assure that security is greater than that of a traditional virtual machine. Containers are leveraging namespaces and other methods if isolation with the underlying server host to provide some potentially powerful protection. It does not mean that by default the container version of your application is more secure. It means that at the lowest possible layers, not including poor application code, SQL injection, XSS and many of a thousand different other attack vectors are solved by deploying in a container versus a traditional virtual machine.</p>
<p>The long and the short of it is that security products, or any technology products for that matter, are inherently insecure unless you deploy them with all of the practices in place around them to ensure the security.</p>
<p>This conversation on Twitter is a nice way to show how challenging it is to convey the message:</p>
<blockquote class="twitter-tweet" data-lang="en">
<p dir="ltr" lang="en">TOTALLY AGREE. Suggesting that containers makes &#8220;apps more secure&#8221; is not correct. Operationalizing them perhaps. <a href="https://t.co/HVrVOaJIlE">https://t.co/HVrVOaJIlE</a></p>
<p>— Hoff (@Beaker) <a href="https://twitter.com/Beaker/status/851105140400689153">April 9, 2017</a></p></blockquote>
<p><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></p>

<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>                            </div>

                            <!--Tags-->
                                                        <div class="tag-box">
                                Tags: <a href="http://discoposse.com/tag/insecure/" rel="tag">Insecure</a>, <a href="http://discoposse.com/tag/security/" rel="tag">security</a>, <a href="http://discoposse.com/tag/tdi/" rel="tag">TDI</a>, <a href="http://discoposse.com/tag/test-driven-infrastructure/" rel="tag">Test-Driven Infrastructure</a>, <a href="http://discoposse.com/tag/vulnerability/" rel="tag">vulnerability</a>                            </div>
                                                        <!--End/Tags-->

                            <!--Foot-->
                            <div class="post-foot">
	    <div class="post-social"><a target="_blank" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fdiscoposse.com%2F2017%2F04%2F09%2Fwhy-your-security-products-are-inherently-insecure%2F&amp;t=Why+your+Security+Products+are+Inherently+Insecure"><i class="fa fa-facebook"></i></a><a target="_blank" href="https://twitter.com/intent/tweet?text=Why+your+Security+Products+are+Inherently+Insecure-http%3A%2F%2Fdiscoposse.com%2F2017%2F04%2F09%2Fwhy-your-security-products-are-inherently-insecure%2F&amp;source=webclient"><i class="fa fa-twitter"></i></a><a target="_blank" href="http://google.com/bookmarks/mark?op=edit&amp;bkmk=http%3A%2F%2Fdiscoposse.com%2F2017%2F04%2F09%2Fwhy-your-security-products-are-inherently-insecure%2F&amp;title=Why+your+Security+Products+are+Inherently+Insecure"><i class="fa fa-google-plus"></i></a><a data-pin-do target="_blank" href="https://pinterest.com/pin/create/button/?url=http%3A%2F%2Fdiscoposse.com%2F2017%2F04%2F09%2Fwhy-your-security-products-are-inherently-insecure%2F&amp;media=https%3A%2F%2Fcdn.discoposse.com%2Fwp-content%2Fuploads%2F2017%2F04%2F09155922%2Ffalse-security.png&amp;description=Why+your+Security+Products+are+Inherently+Insecure"><i class="fa fa-pinterest"></i></a></div></div>
                            <!--End/Foot-->
                        </div>
                   </article>
                    <div class="about-author">
	<div class="image-thumb fl"><img src="http://cdn.discoposse.com/wp-content/uploads/2015/11/EricWrightPicture.png"  alt="DiscoPosse"></div><div class="author-info"><div class="author-name"><h4 class="text-uppercase"><a href="http://discoposse.com/author/discoposse/">DiscoPosse</a></h4></div><div class="author-content"><p>People, Process, and Technology.  Powered by Community!</p></div><div class="author-social"><a target="_blank" href="http://Twitter.com/DiscoPosse"><i class="fa fa-twitter"></i></a><a target="_blank" href="https://plus.google.com/u/0/+EricWrightDiscoPosse"><i class="fa fa-google-plus"></i></a><a target="_blank" href="http://www.youtube.com/DiscoPosse"><i class="fa fa-youtube-play"></i></a></div></div>    <div class="pi-border">
        <span></span>
        <span></span>
    </div>
</div>                    
                                    <div class="related-post pi-related_posts">
                    <h3 class="related-post-title">You might also like</h3>                    <div class="pi-row">
                                                    <div class="pi-three-column">
                                <div class="related-post-item">
                                    <div class="post-media">
                                        <div class="image-wrap">
                                            <a href="http://discoposse.com/2017/02/14/using-terraform-to-install-devstack-on-digitalocean/" rel="bookmark">
                                            <img width="250" height="160" src="https://cdn.discoposse.com/wp-content/uploads/2017/02/14124927/devstack-header-250x160.png" class="attachment-pi-relate-post size-pi-relate-post wp-post-image" alt="" data-attachment-id="6331" data-permalink="http://discoposse.com/2017/02/14/using-terraform-to-install-devstack-on-digitalocean/devstack-header/" data-orig-file="https://cdn.discoposse.com/wp-content/uploads/2017/02/14124927/devstack-header.png" data-orig-size="3352,792" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="devstack-header" data-image-description="" data-medium-file="https://cdn.discoposse.com/wp-content/uploads/2017/02/14124927/devstack-header-300x71.png" data-large-file="https://cdn.discoposse.com/wp-content/uploads/2017/02/14124927/devstack-header-1024x242.png" />                                            </a>
                                        </div>
                                    </div>
                                    <div class="post-body">
                                        <div class="post-title">
                                            <h2><a href="http://discoposse.com/2017/02/14/using-terraform-to-install-devstack-on-digitalocean/" rel="bookmark">Using Terraform to Install DevStack on DigitalOcean</a></h2>
                                        </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="pi-three-column">
                                <div class="related-post-item">
                                    <div class="post-media">
                                        <div class="image-wrap">
                                            <a href="http://discoposse.com/2017/02/08/adding-ssh-access-for-digitalocean-when-using-terraform/" rel="bookmark">
                                            <img width="250" height="160" src="https://cdn.discoposse.com/wp-content/uploads/2017/02/04215244/terraform-apply-web-250x160.png" class="attachment-pi-relate-post size-pi-relate-post wp-post-image" alt="" data-attachment-id="6321" data-permalink="http://discoposse.com/2017/02/08/adding-ssh-access-for-digitalocean-when-using-terraform/terraform-apply-web/" data-orig-file="https://cdn.discoposse.com/wp-content/uploads/2017/02/04215244/terraform-apply-web.png" data-orig-size="1120,438" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="terraform-apply-web" data-image-description="" data-medium-file="https://cdn.discoposse.com/wp-content/uploads/2017/02/04215244/terraform-apply-web-300x117.png" data-large-file="https://cdn.discoposse.com/wp-content/uploads/2017/02/04215244/terraform-apply-web-1024x400.png" />                                            </a>
                                        </div>
                                    </div>
                                    <div class="post-body">
                                        <div class="post-title">
                                            <h2><a href="http://discoposse.com/2017/02/08/adding-ssh-access-for-digitalocean-when-using-terraform/" rel="bookmark">Adding SSH Access for DigitalOcean when Using Terraform</a></h2>
                                        </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="pi-three-column">
                                <div class="related-post-item">
                                    <div class="post-media">
                                        <div class="image-wrap">
                                            <a href="http://discoposse.com/2017/02/04/accessing-digitalocean-droplets-via-command-line-using-ssh-keys-on-osx/" rel="bookmark">
                                            <img width="250" height="160" src="https://cdn.discoposse.com/wp-content/uploads/2017/02/04195735/ssh-add-250x160.png" class="attachment-pi-relate-post size-pi-relate-post wp-post-image" alt="" data-attachment-id="6310" data-permalink="http://discoposse.com/2017/02/04/accessing-digitalocean-droplets-via-command-line-using-ssh-keys-on-osx/ssh-add/" data-orig-file="https://cdn.discoposse.com/wp-content/uploads/2017/02/04195735/ssh-add.png" data-orig-size="1136,212" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ssh-add" data-image-description="" data-medium-file="https://cdn.discoposse.com/wp-content/uploads/2017/02/04195735/ssh-add-300x56.png" data-large-file="https://cdn.discoposse.com/wp-content/uploads/2017/02/04195735/ssh-add-1024x191.png" />                                            </a>
                                        </div>
                                    </div>
                                    <div class="post-body">
                                        <div class="post-title">
                                            <h2><a href="http://discoposse.com/2017/02/04/accessing-digitalocean-droplets-via-command-line-using-ssh-keys-on-osx/" rel="bookmark">Accessing DigitalOcean Droplets via Command Line Using SSH Keys on OSX</a></h2>
                                        </div>
                                    </div>
                                </div>
                            </div>
                                            </div>
                </div>
                                <div id="comments">
    <div class="comments-inner-wrap">
            <!-- LEAVER YOUR COMMENT -->
        </div>
    </div>
    	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A COMMENT <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/04/09/why-your-security-products-are-inherently-insecure/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://discoposse.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<div class="form-item form-textarea"><textarea id="comment" placeholder="Your Message *" name="comment"  tabindex="4"	class="tb-eff"></textarea></div><div class="form-item form-name"><input type="text" id="author" name="author" placeholder="Your name *" tabindex="1" value=""  aria-required='true' /></div>
<div class="form-item form-email"><input type="text" placeholder="Your email *" id="email" name="email" tabindex="2" value=""  aria-required='true' /></div>
<div class="form-item form-website"><input type="text" placeholder="Your website" name="url" id="url" tabindex="3" value=""  aria-required='true' /></div>
<!-- MailChimp for WordPress v4.1.0 - https://mc4wp.com/ --><input type="hidden" name="_mc4wp_subscribe_wp-comment-form" value="0" /><p class="mc4wp-checkbox mc4wp-checkbox-wp-comment-form"><label><input type="checkbox" name="_mc4wp_subscribe_wp-comment-form" value="1" checked="checked" /><span>Sign me up for the newsletter!</span></label></p><!-- / MailChimp for WordPress --><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='6391' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="71c4938de4" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="74"/></p>			</form>
			</div><!-- #respond -->
	
    <!-- END / LEAVER YOUR COMMENT -->
                                    </div>
                <!-- Sidebar -->
<div class="pi-sidebar">
    <div id="search-2" class="widget widget_search"><form class="search" method="get" action="http://discoposse.com/">
	<label>
		<input type="search" class="search-field" placeholder="Search …" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="">
</form></div><div id="text-2" class="widget widget_text"><h4 class="widget-title">Proudly Sponsored By</h4>			<div class="textwidget"><p align="center">
<a href="http://bit.ly/2k9U5s4"><img src="https://cdn.discoposse.com/wp-content/uploads/2017/01/31162743/ANIMATED-Gray-Border-Lightning-Fast-125x125.gif" border="0" width="125" /></a>
<a href="https://www.nutanix.com/testdrive/?utm_source=blogger_network&utm_campaign=test_drive&utm_medium=ad"><img src="https://cdn.discoposse.com/wp-content/uploads/2017/01/19161610/125X125-ATestDrive.jpg" border="0" width="125" /></a>
<br />
<A HREF="https://ad.doubleclick.net/ddm/jump/N410401.1772602DISCOPOSSE.COM/B10464038.143709352;sz=125x125;ord=[timestamp]?">

<IMG SRC="https://ad.doubleclick.net/ddm/ad/N410401.1772602DISCOPOSSE.COM/B10464038.143709352;sz=125x125;ord=[timestamp];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER=0 WIDTH=125 HEIGHT=125 ALT="Advertisement"></A>

<a href="https://www.vembu.com/vembu-bdr-suite-free-edition/?utm_source=DiscoPosse&utm_campaign=BDRSuite&utm_medium=Banner"><img src="https://cdn.discoposse.com/wp-content/uploads/2017/03/27072445/Vembu-free-vm-backup125.png" border="0" width="125" /></a>

<br />
<a href="http://turbonomic.com/free-tool-vhm-fiber-optic/?utm_source=discoposse&utm_medium=banner-ad&utm_campaign=vhm-fiber-optic&utm_content=250x125"><img src="http://cdn.discoposse.com/wp-content/uploads/2016/08/vhm-fiber-optic250x125.png" border="0" width="250"></a>
<br />
</p></div>
		</div><div id="text-4" class="widget widget_text"><h4 class="widget-title">GC On-Demand</h4>			<div class="textwidget"><iframe id="multi_iframe" frameborder="0" scrolling="no" allowfullscreen="" src="http://www.podbean.com/media/player/multi?playlist=http%3A%2F%2Fplaylist.podbean.com%2F924537%2Fplaylist_multi.xml&vjs=1&kdsowie31j4k1jlf912=ac6d774351f76dc2ca70eb74701910236a51777d&size=80&share=1&fonts=Helvetica&auto=0&skin=6" width="100%" height="270"></iframe></div>
		</div><div id="blog_subscription-3" class="widget jetpack_subscription_widget"><h4 class="widget-title">Subscribe to the Blog</h4>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				<div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div>					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-3">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-3" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="http://discoposse.com/2017/04/09/why-your-security-products-are-inherently-insecure/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-3" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-3]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-3'),
					input = d.getElementById('subscribe-field-blog_subscription-3'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</div><div id="event_list_widget-2" class="widget widget_event_list_widget"><h4 class="widget-title">Upcoming events:</h4>
				<div class="event-list">
				<ul class="event-list-view">
			 	<li class="event vmug">
					<div class="event-date"><div class="end-date"><div class="event-weekday">Fri</div><div class="event-day">28</div><div class="event-month">Apr</div><div class="event-year">2017</div></div></div>
					<div class="event-info multi-day"><div class="event-title"><h3><a href="http://www.discoposse.com/events?event_id1=22">Denver VMUG UserCon - Keynote Speaker</a></h3></div><span class="event-location">Denver, CO</span></div>
				</li>
			 	<li class="event conference">
					<div class="event-date multi-date"><div class="start-date"><div class="event-weekday">Mon</div><div class="event-day">15</div><div class="event-month">May</div><div class="event-year">2017</div></div><div class="end-date"><div class="event-weekday">Fri</div><div class="event-day">19</div><div class="event-month">May</div><div class="event-year">2017</div></div></div>
					<div class="event-info multi-day"><div class="event-title"><h3><a href="http://www.discoposse.com/events?event_id1=17">Interop ITX</a></h3></div><span class="event-location">Las Vegas, NV</span></div>
				</li>
			 	<li class="event conference">
					<div class="event-date multi-date"><div class="start-date"><div class="event-weekday">Sun</div><div class="event-day">27</div><div class="event-month">Aug</div><div class="event-year">2017</div></div><div class="end-date"><div class="event-weekday">Fri</div><div class="event-day">01</div><div class="event-month">Sep</div><div class="event-year">2017</div></div></div>
					<div class="event-info multi-day"><div class="event-title"><h3><a href="http://www.discoposse.com/events?event_id1=18">VMworld 2017 US</a></h3></div><span class="event-location">Las Vegas, NV</span></div>
				</li>
			 	<li class="event conference">
					<div class="event-date multi-date"><div class="start-date"><div class="event-weekday">Tue</div><div class="event-day">26</div><div class="event-month">Sep</div><div class="event-year">2017</div></div><div class="end-date"><div class="event-weekday">Thu</div><div class="event-day">28</div><div class="event-month">Sep</div><div class="event-year">2017</div></div></div>
					<div class="event-info multi-day"><div class="event-title"><h3><a href="http://www.discoposse.com/events?event_id1=16">SDxE - Software-Defined Enterprise Conference</a></h3></div><span class="event-location">Austin, TX</span></div>
				</li></ul>
				</div><div style="clear:both"><a title="show events page" href="http://www.discoposse.com/events">show events page</a></div></div><div id="github-profile-2" class="widget widget_github-profile"><aside><h4 class="widget-title">DiscoPosse on GitHub</h4><div class="github-widget" id="github-profile-2"><header class="github-widget-header"><img class="github-widget-company-logo" title="GitHub" src="https://assets-cdn.github.com/favicon.ico"/><div class="github-widget-header-text"><a class="github-widget-header-link" target="_blank" href="https://github.com/discoposse" title="View profile">discoposse (Eric Wright)</a></div></header><div class="github-widget-content"><a target="_blank" href="https://github.com/discoposse" title="View profile"><img class="github-profile-pic" src="https://avatars2.githubusercontent.com/u/120960?v=3" style="border-radius: 5px"> <span class="github-names"> <p class="github-name">Eric Wright</p> <span class="github-username">discoposse</span> </span></a><div class="github-block with-icons"><div title="Company"><span	class="octicon octicon-organization"></span>DiscoPosse</div><div title="Location"><span	class="octicon octicon-location"></span>Toronto</div><div title="Blog"><span class="octicon octicon-link"></span><a href="www.discoposse.com" target="_blank">www.discoposse.com</a></div><div><span class="octicon octicon-clock"></span>Joined on Aug 29, 2009</div></div><div class="github-block github-vcard-stats"><a class="github-vcard-stat" target='_blank' href="https://github.com/discoposse/followers"><strong class="github-vcard-stat-count">24</strong><span class="text-muted">Followers</span></a><a class="github-vcard-stat" target='_blank' href="https://github.com/discoposse/following"><strong class="github-vcard-stat-count">70</strong><span class="text-muted">Following</span></a><div style="clear: both;"></div></div><div class="github-block with-icons"><div><span class="octicon octicon-repo"></span><a href="https://github.com/discoposse/repositories" target="_blank">87 Public Repositories</a><input type="checkbox" id="gh-repo-t" class="github-repos-toggle"><label for="gh-repo-t" class="github-repos-toggle-la octicon octicon-chevron-down"></label><div class="github-repos"><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/12-days-of-commitmas" title="discoposse/12-days-of-commitmas">12-days-of-commitmas</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/30-days-of-commitmas-2015" title="discoposse/30-days-of-commitmas-2015">30-days-of-commitmas-2015</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/4Dpubs" title="discoposse/4Dpubs">4Dpubs</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/aac-lib" title="discoposse/aac-lib">aac-lib</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/awesome-kubernetes" title="discoposse/awesome-kubernetes">awesome-kubernetes</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/AzureStack-QuickStart-Templates" title="discoposse/AzureStack-QuickStart-Templates">AzureStack-QuickStart-Templates</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/blacklight" title="discoposse/blacklight">blacklight</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/ChefCookbooks" title="discoposse/ChefCookbooks">ChefCookbooks</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/clarity" title="discoposse/clarity">clarity</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/CodeDeploySample" title="discoposse/CodeDeploySample">CodeDeploySample</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/consul-do" title="discoposse/consul-do">consul-do</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/coreos-ipxe-server" title="discoposse/coreos-ipxe-server">coreos-ipxe-server</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/Couch_to_OpenStack" title="discoposse/Couch_to_OpenStack">Couch_to_OpenStack</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/customize-vsphere-web-client-6.0u2" title="discoposse/customize-vsphere-web-client-6.0u2">customize-vsphere-web-client-6.0u2</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/dcos" title="discoposse/dcos">dcos</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/dcos-docs" title="discoposse/dcos-docs">dcos-docs</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/dcos-vagrant" title="discoposse/dcos-vagrant">dcos-vagrant</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/DeployImage" title="discoposse/DeployImage">DeployImage</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/devstack-vagrant" title="discoposse/devstack-vagrant">devstack-vagrant</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/discoposse.github.io" title="discoposse/discoposse.github.io">discoposse.github.io</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/docker-jekyll" title="discoposse/docker-jekyll">docker-jekyll</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/docker-solr" title="discoposse/docker-solr">docker-solr</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/docker-wordpress-nginx" title="discoposse/docker-wordpress-nginx">docker-wordpress-nginx</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/doesitscale" title="discoposse/doesitscale">doesitscale</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/flashcard" title="discoposse/flashcard">flashcard</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/galera-mariadb-3node-vagrant-virtualbox" title="discoposse/galera-mariadb-3node-vagrant-virtualbox">galera-mariadb-3node-vagrant-virtualbox</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/gollum" title="discoposse/gollum">gollum</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/itsonpremises-web" title="discoposse/itsonpremises-web">itsonpremises-web</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/kubernetes" title="discoposse/kubernetes">kubernetes</a></div><div class="github-repo-name"><a target="_blank" href="https://github.com/discoposse/kubeturbo" title="discoposse/kubeturbo">kubeturbo</a></div></div></div><div><span class="octicon octicon-gist"></span><a href="https://gist.github.com/discoposse" target="_blank">13 Public Gists</a></div></div> </div></div></aside></div><div id="archives-2" class="widget widget_archive"><h4 class="widget-title">Archives</h4>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://discoposse.com/2017/04/'> April 2017 &nbsp;(1)</option>
	<option value='http://discoposse.com/2017/03/'> March 2017 &nbsp;(2)</option>
	<option value='http://discoposse.com/2017/02/'> February 2017 &nbsp;(3)</option>
	<option value='http://discoposse.com/2017/01/'> January 2017 &nbsp;(6)</option>
	<option value='http://discoposse.com/2016/12/'> December 2016 &nbsp;(1)</option>
	<option value='http://discoposse.com/2016/11/'> November 2016 &nbsp;(17)</option>
	<option value='http://discoposse.com/2016/10/'> October 2016 &nbsp;(4)</option>
	<option value='http://discoposse.com/2016/09/'> September 2016 &nbsp;(10)</option>
	<option value='http://discoposse.com/2016/08/'> August 2016 &nbsp;(8)</option>
	<option value='http://discoposse.com/2016/07/'> July 2016 &nbsp;(1)</option>
	<option value='http://discoposse.com/2016/06/'> June 2016 &nbsp;(3)</option>
	<option value='http://discoposse.com/2016/05/'> May 2016 &nbsp;(9)</option>
	<option value='http://discoposse.com/2016/04/'> April 2016 &nbsp;(3)</option>
	<option value='http://discoposse.com/2016/03/'> March 2016 &nbsp;(4)</option>
	<option value='http://discoposse.com/2016/02/'> February 2016 &nbsp;(3)</option>
	<option value='http://discoposse.com/2015/12/'> December 2015 &nbsp;(3)</option>
	<option value='http://discoposse.com/2015/11/'> November 2015 &nbsp;(19)</option>
	<option value='http://discoposse.com/2015/10/'> October 2015 &nbsp;(1)</option>
	<option value='http://discoposse.com/2015/09/'> September 2015 &nbsp;(1)</option>
	<option value='http://discoposse.com/2015/08/'> August 2015 &nbsp;(3)</option>
	<option value='http://discoposse.com/2015/07/'> July 2015 &nbsp;(3)</option>
	<option value='http://discoposse.com/2015/06/'> June 2015 &nbsp;(2)</option>
	<option value='http://discoposse.com/2015/05/'> May 2015 &nbsp;(2)</option>
	<option value='http://discoposse.com/2015/04/'> April 2015 &nbsp;(4)</option>
	<option value='http://discoposse.com/2015/03/'> March 2015 &nbsp;(2)</option>
	<option value='http://discoposse.com/2015/02/'> February 2015 &nbsp;(4)</option>
	<option value='http://discoposse.com/2015/01/'> January 2015 &nbsp;(1)</option>
	<option value='http://discoposse.com/2014/12/'> December 2014 &nbsp;(1)</option>
	<option value='http://discoposse.com/2014/11/'> November 2014 &nbsp;(30)</option>
	<option value='http://discoposse.com/2014/10/'> October 2014 &nbsp;(2)</option>
	<option value='http://discoposse.com/2014/09/'> September 2014 &nbsp;(2)</option>
	<option value='http://discoposse.com/2014/08/'> August 2014 &nbsp;(7)</option>
	<option value='http://discoposse.com/2014/07/'> July 2014 &nbsp;(6)</option>
	<option value='http://discoposse.com/2014/06/'> June 2014 &nbsp;(7)</option>
	<option value='http://discoposse.com/2014/05/'> May 2014 &nbsp;(8)</option>
	<option value='http://discoposse.com/2014/04/'> April 2014 &nbsp;(7)</option>
	<option value='http://discoposse.com/2014/03/'> March 2014 &nbsp;(17)</option>
	<option value='http://discoposse.com/2014/02/'> February 2014 &nbsp;(6)</option>
	<option value='http://discoposse.com/2014/01/'> January 2014 &nbsp;(7)</option>
	<option value='http://discoposse.com/2013/12/'> December 2013 &nbsp;(12)</option>
	<option value='http://discoposse.com/2013/11/'> November 2013 &nbsp;(9)</option>
	<option value='http://discoposse.com/2013/10/'> October 2013 &nbsp;(6)</option>
	<option value='http://discoposse.com/2013/09/'> September 2013 &nbsp;(4)</option>
	<option value='http://discoposse.com/2013/08/'> August 2013 &nbsp;(6)</option>
	<option value='http://discoposse.com/2013/07/'> July 2013 &nbsp;(6)</option>
	<option value='http://discoposse.com/2013/06/'> June 2013 &nbsp;(2)</option>
	<option value='http://discoposse.com/2013/05/'> May 2013 &nbsp;(6)</option>
	<option value='http://discoposse.com/2013/04/'> April 2013 &nbsp;(3)</option>
	<option value='http://discoposse.com/2013/03/'> March 2013 &nbsp;(8)</option>
	<option value='http://discoposse.com/2013/02/'> February 2013 &nbsp;(7)</option>
	<option value='http://discoposse.com/2013/01/'> January 2013 &nbsp;(3)</option>
	<option value='http://discoposse.com/2012/12/'> December 2012 &nbsp;(8)</option>
	<option value='http://discoposse.com/2012/11/'> November 2012 &nbsp;(2)</option>
	<option value='http://discoposse.com/2012/10/'> October 2012 &nbsp;(6)</option>
	<option value='http://discoposse.com/2012/09/'> September 2012 &nbsp;(9)</option>
	<option value='http://discoposse.com/2012/08/'> August 2012 &nbsp;(10)</option>
	<option value='http://discoposse.com/2012/07/'> July 2012 &nbsp;(11)</option>
	<option value='http://discoposse.com/2012/06/'> June 2012 &nbsp;(6)</option>
	<option value='http://discoposse.com/2012/05/'> May 2012 &nbsp;(4)</option>
	<option value='http://discoposse.com/2012/04/'> April 2012 &nbsp;(6)</option>
	<option value='http://discoposse.com/2012/03/'> March 2012 &nbsp;(4)</option>
	<option value='http://discoposse.com/2012/02/'> February 2012 &nbsp;(5)</option>
	<option value='http://discoposse.com/2012/01/'> January 2012 &nbsp;(4)</option>
	<option value='http://discoposse.com/2011/12/'> December 2011 &nbsp;(2)</option>
	<option value='http://discoposse.com/2011/11/'> November 2011 &nbsp;(2)</option>
	<option value='http://discoposse.com/2011/10/'> October 2011 &nbsp;(4)</option>
	<option value='http://discoposse.com/2011/09/'> September 2011 &nbsp;(4)</option>
	<option value='http://discoposse.com/2011/08/'> August 2011 &nbsp;(2)</option>
	<option value='http://discoposse.com/2011/07/'> July 2011 &nbsp;(1)</option>
	<option value='http://discoposse.com/2011/01/'> January 2011 &nbsp;(2)</option>
	<option value='http://discoposse.com/2010/12/'> December 2010 &nbsp;(2)</option>
	<option value='http://discoposse.com/2010/09/'> September 2010 &nbsp;(3)</option>
	<option value='http://discoposse.com/2010/08/'> August 2010 &nbsp;(1)</option>
	<option value='http://discoposse.com/2010/07/'> July 2010 &nbsp;(4)</option>
	<option value='http://discoposse.com/2010/06/'> June 2010 &nbsp;(3)</option>
	<option value='http://discoposse.com/2010/05/'> May 2010 &nbsp;(4)</option>
	<option value='http://discoposse.com/2010/04/'> April 2010 &nbsp;(1)</option>
	<option value='http://discoposse.com/2010/02/'> February 2010 &nbsp;(5)</option>
	<option value='http://discoposse.com/2010/01/'> January 2010 &nbsp;(9)</option>

		</select>
		</div></div>
<!-- / Sidebar -->            </div>
        </div>
    </section>
          
        <div class="pi-nav-thumbnail">
                        <div class="prev">
                <a href="http://discoposse.com/2017/03/21/one-vault-to-secure-them-all-hashicorp-releases-vault-enterprise-0-7/">
                    <div class="image-cover">
                                                <img width="150" height="150" src="https://cdn.discoposse.com/wp-content/uploads/2017/03/20221135/vault-header-150x150.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-attachment-id="6368" data-permalink="http://discoposse.com/2017/03/21/one-vault-to-secure-them-all-hashicorp-releases-vault-enterprise-0-7/vault-header/" data-orig-file="https://cdn.discoposse.com/wp-content/uploads/2017/03/20221135/vault-header.png" data-orig-size="3108,340" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="vault-header" data-image-description="" data-medium-file="https://cdn.discoposse.com/wp-content/uploads/2017/03/20221135/vault-header-300x33.png" data-large-file="https://cdn.discoposse.com/wp-content/uploads/2017/03/20221135/vault-header-1024x112.png" />                                            </div>
                    <h4>One Vault to Secure Them All:  HashiCorp Releases Vault Enterprise 0.7</h4>
                    <i class="fa fa-angle-left"></i>
                </a>
            </div>
                                </div>
        
                <!-- Sidebar -->
<div id="pi-secondary-sidebar-wrapper" class="widget-expand">
    <span class="widget-toggle">
    Widgets<i class="fa fa-angle-up"></i>
    </span>
    <div id="widget-expand-content" class="widget-expand-content">
        </div>
</div>
<!-- / Sidebar -->                <footer id="pi-footer">
                    <div class="footer-social"><div class="pi-container"><a href="https://twitter.com/DiscoPosse" target="_blank"><i class="fa fa-twitter"></i>Twitter</a><a href="http://www.youtube.com/DiscoPosse" target="_blank"><i class="fa fa-youtube-play"></i>Youtube</a></div><div class="pi-border"><span></span><span></span></div></div>                                        <div class="copyright"><p>Powered by Community</p></div>                </footer>
            </div> <!-- End / wrapper -->
        <meta id="ba_s" property="options" content="" data-o="{&quot;tid&quot;:&quot;UA-22628890-1&quot;,&quot;et&quot;:15,&quot;co&quot;:&quot;auto&quot;,&quot;g&quot;:1074203624,&quot;dl&quot;:&quot;\\.avi|\\.doc|\\.exe|\\.gz|\\.mpg|\\.mp3|\\.pdf|\\.ppt|\\.psd|\\.rar|\\.wmv|\\.xls|\\.zip&quot;,&quot;s&quot;:36,&quot;a&quot;:0,&quot;d&quot;:{&quot;c&quot;:[1,&quot;Cloud, Virtualization and Architecture&quot;],&quot;a&quot;:[2,&quot;DiscoPosse&quot;],&quot;t&quot;:[3,&quot;Insecure,security,TDI,Test-Driven Infrastructure,vulnerability&quot;],&quot;y&quot;:[4,2017],&quot;r&quot;:[5,&quot;guest&quot;]}}" />	<div style="display:none">
	</div>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/plugins/akismet/_inc/form.js.gzip?ver=3.3'></script>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://cdn.discoposse.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css.gzip?ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='github-profile-widget-styles-css'  href='http://cdn.discoposse.com/wp-content/plugins/github-profile-widget/css/widget.css.gzip?ver=4.7.3' type='text/css' media='all' />
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js.gzip?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/plugins/contact-form-7/includes/js/scripts.js.gzip?ver=4.7'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201714'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Apraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/plugins/jetpack/modules/wpgroho.js.gzip?ver=4.7.3'></script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-includes/js/comment-reply.min.js.gzip?ver=4.7.3'></script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/themes/titan/js/lib/plugins.min.js.gzip?ver=1.0'></script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/themes/titan/js/scripts.js.gzip?ver=1.0'></script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-includes/js/wp-embed.min.js.gzip?ver=4.7.3'></script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/plugins/jetpack/_inc/spin.js.gzip?ver=1.3'></script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/plugins/jetpack/_inc/jquery.spin.js.gzip?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/discoposse.com\/wp-admin\/admin-ajax.php","nonce":"ac64217b79","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/discoposse.com\/wp-login.php?redirect_to=http%3A%2F%2Fdiscoposse.com%2F2017%2F04%2F09%2Fwhy-your-security-products-are-inherently-insecure%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://cdn.discoposse.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js.gzip?ver=20170209'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201714.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.8.2',blog:'100848524',post:'6391',tz:'-4',srv:'discoposse.com'} ]);
	_stq.push([ 'clickTrackerInit', '100848524', '6391' ]);
</script>
    </body>
</html>
<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Content Delivery Network via Amazon Web Services: S3: cdn.discoposse.com

 Served from: discoposse.com @ 2017-04-09 19:37:10 by W3 Total Cache -->