Unable to use VeeamZip with VMware Free Hypervisor: Understanding Why

image_pdfimage_print

This week a question was posed to me from a fellow VMUG community member. The question asked was whether it was possible to use VeeamZip (aka Veeam Backup Free Edition) with the VMware ESXi Free Hypervisor. Great question.

Let’s start with the unfortunate answer, which is…no. Not the answer we would like to see, but the real meat of the situation is in why the answer is no.

To confirm, you can check the Veeam Forums (http://forums.veeam.com/viewtopic.php?f=21&t=9329&start=0#p39896) and read the Q&A which shows the following for supported editions:

Because I’m a little stubborn, I wanted to dive a little deeper than just accepting the situation and I wanted to be sure that this was truly the case and that there was no way to dodge the issue with some light hacking.

NOTE: This is being done just for test purposes and is only being done in a lab environment. Do not make these changes to your production machines.

If you don’t already have your copy of Veeam Backup Free Edition, follow this link (opens in a new page) and download away!

Understanding Veeam Backup for VMware

Veeam Backup takes advantage of the Change Block Tracking (CBT) technology which is baked into the VMware Hypervisor. CBT is used by vSphere to manage VM changes for its incremental backups. This is required to give the full features in the VMware Data Recovery (VDR) product.

VMware explains this in the following KB article: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1020128

As the article explains, VMware exposes the abilities of CBT for backup vendors to also take advantage of this cool technology. Share and share alike 🙂

CBT and the vSphere ESXi Free Hypervisor

Let’s take a look at a sample system to show what the settings are using the vSphere ESXi Hypervisor which is the free version which can be used as a standalone host with some stripped back functionality.

This is my vSphere server, which you can see is running the unlimited license of the free hypervisor:

So just to show what our configuration is out of the box, we can run a quick PowerCLI script to show whether the ChangeTrackingStatus property is enabled on our VM.

So we have confirmed that the option is False on our SRV01 virtual machine. Next, let’s look at the configuration properties inside the vSphere Client to confirm what PowerCLI has shown us. We are going to look for a property named ctkEnabled and scsi:x:x.ctkEnabled for the VMDK file.

So as you can see, there is no ctkEnabled option at all. To confirm that the property is required, I will run the VeeamZip process to be sure.

Here is the result of running the VeeamZip to C:Backup option inside the Veeam Backup Free Edition:

No surprises. The backup failed, and as clearly noted in the job details you can see the message:

11/17/2012 7:40:28 AM :: SetVmChangeTracking failed, vmRef ‘1’, changeTrackingEnabled ‘True’
Current license or ESXi version prohibits execution of the requested operation.

Using some PowerCLI magic, I want to try to set the ctkEnabled property as TRUE for my virtual machine. There is a great little function script posted by Arne Fokkema over at ict-freak.nl which you can find here: http://ict-freak.nl/2009/12/14/powercli-enable-changed-block-tracking/

The PowerCLI process clearly shows us that it is the ESXi licensing that is preventing us from setting up the properties to leverage the CBT for what we want to do.

I like to push the limits of my software wherever possible. So what do you think would happen if we were to fool with nature a little, and add the ctkEnabled property to my VM? This is clearly diving deep into the unsupported realm.

Next I create the scsi0:0.ctkEnabled property since we only have one volume to manage. By doing this, I’m simulating the CBT properties being enabled which should be the technical feature required to use this process provided licensing isn’t really the issue.

I’ll use my PowerCLI script to check the settings and show whether the machine recognizes the change tracking properties.

According to the VM properties, it looks like we could be good to go. Time to test the waters by re-running my VeeamZip to see if the changes made have bypassed the limitation because of my choice in hypervisor.

We’ve done all that we can do to try to get around the supportable features of the VMware hypervisor but the end result is the same.

So the moral of the story here is that you will need to have at least Essentials edition licensing enabled on your vSphere server to be able to use the Veeam Backup & Replication Free Edition, and now we can fully understand the background as to why.

DiscoPosse

People, Process, and Technology. Powered by Community!

You might also like

20 Comments

  • Biker
    November 17, 2012 at 2:35 pm

    Just backuped 3 VM’s (powered off) from ESXi 4.1 Hypervisor and restored to ESXi 5.1 Hypervisor with Veeam Backup 6.1 Free Edition. It works well, do I missed something?

    • DiscoPosse
      Eric
      November 17, 2012 at 4:40 pm

      Hmmm, that’s a great question. Are you definitely Hypervisor free? or possibly on trial edition license which enables all of the features?

  • Biker
    November 18, 2012 at 3:40 am

    Definitely both ESXi 5.1 and 4.1 are the free Hypervisor versions. Using Veeam Backup 6.5 Free Edition 6.1.0.205 x64. After upgrading to version 6.5 two weeks ago the backup fails so I did a downgrade to version 6.1 and again it was working.

  • Biker
    November 18, 2012 at 7:42 am

    Sorry I mean “Using Veeam Backup 6.1 Free Edition”.

  • raymond
    July 23, 2013 at 4:19 am

    I am using (free) ESXi 5.1 with (free) veeam backup 6.5

    I can backup a VM (live without shutting it down) on a (free ESXi 5.1) server. I backup the VM to a directory on my PC using VeeamZIP. I can then restore the VM so it works on VMware player on my PC. (So I am running the VM that I took from ESXi server and made it work on vmplayer on my destop pc) The VM works fine when I run it on my PC. I get no errors… I am confused as the website clearly states that you can not use veeam with the free version of ESXi…. ??? I am very confused at the moment. I was hoping to use the the combination of Free ESXi and free Veeam backup in a production environment. Anyone have some clues here ?

    • DiscoPosse
      Eric
      July 23, 2013 at 6:16 am

      Hi Raymond,

      Thank you for your comment. I’m very curious to see if there has been a change in the free hypervisor as a result of a patch version. I’ll have to spin up a test instance to see how it goes.

      If you don’t mind, can you confirm the full version number of your ESXi instance (i.e. 5.1.0 12345) so that I can make sure I am using a similar instance.

      Thanks!

      Eric

      • raymond
        July 23, 2013 at 7:54 am

        sorry, in my post I said that it is 5.1 but I checked and it is 5.0.0, 469512

        I am using 5.1 at home…. The veeam backup 6.5 works with 5.0.0

        I asked the veeam team and they said the it is an error by the vmware team when they released ver 5.0 and that it will be fixed with later updates.

        I have not yet tested veeam backup on version 5.1

        • DiscoPosse
          Eric
          July 23, 2013 at 8:56 am

          Thanks for the feedback Raymond. I believe that is the case for this situation. With 5.1 there were changes to the storage level in the hypervisor which could be the reason for it not working. I will do my best to spin up a 5.0 server to confirm.

          Eric

  • RAUL
    August 13, 2013 at 7:33 am

    Hello guys. After reading several articles regarding this issue, I see there’s no other way than downgrading to v. 5.0.0. My problem now is that I can’t find that version. There’s one 5.0.0 U2 available in VMware website, but I’m almost sure this version is fixed to not to work with Veeam (free) 6.5.

    It would be possible for someone here to put the ISO (v 5.0.0) for a quick download? I’ll keep searching anyway.

    Thanks in advance. Kind regards.

    • DiscoPosse
      Eric
      August 15, 2013 at 4:30 am

      Hi Raul,

      The legacy 5.0 image seems to be unavailable now, but I’d suggest trying 5.0.0 U2 edition to confirm. I don’t have a copy of the previous edition unfortunately. I’ll see if I can find a source and let you know if there is somewhere to be able to get that one.

      Thanks…Eric

  • RAUL
    August 15, 2013 at 8:11 am

    Hi Eric. I’ve found and installed ESXi 5.0.0.469512 in other box and the Veeam (free) works great! I’ve tried versions 6.1.181 and 6.5.109, both of ’em working ok.

    The ESXi version was downloaded from MyVMware. It seems no to be the U2 version but I’m not sure.

    Kind regards.

  • Jerry Ray
    September 12, 2013 at 1:11 pm

    Just for the record, the Veeam 6.1 will work with the 4.1 free hypervisor. Although you cannot find 5.0 on the site, 4.1 is still available for download and the 6.1 release of Veeam does do live backup with this version of the free hypervisor.

    • DiscoPosse
      Eric
      September 14, 2013 at 5:58 am

      Thanks for the tip Jerry! That’s good to know.

  • lh
    May 2, 2014 at 5:00 pm

    What a bunch of crap

  • lh
    May 2, 2014 at 5:01 pm

    Can they tell us this before we go through the whole stupid install???????

    • DiscoPosse
      Eric
      May 5, 2014 at 7:53 pm

      It is a bit of a challenge when we find these limitations. Unfortunately it required some digging by many which led to what’s inside the FAQ on it. I understand the frustration it can create when we hit the wall on this one.

  • Jeff Mailly
    March 27, 2015 at 1:06 pm

    For anyone who stumbles upon this article like I did, please see this post in the VMware KB stating how to correct the issue. I almost took this article as the truth and decided to Google a bit further. Just upgraded from ESXi 5.0 to 5.5 and lost the ability to backup using free Veeam Zip. All I did was follow the directions at the URL below and it works fine now.

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1031873

    • DiscoPosse
      Eric
      March 27, 2015 at 4:47 pm

      Thanks for the update Jeff!! This is a great tip.

  • Pavel
    April 19, 2015 at 4:59 am

    Hi guys,
    Please tell if Jeff solution (Mar27) works for ESXi 5.5 U2?
    I turned on ctkEnabled options but no luck… See the same error 🙁

    • TiriPon
      October 28, 2015 at 8:39 pm

      I am on ESXi 5.5 U2 and it did not work for me too. I noticed that after adding the line “ctkEnabled” and setting it to true it won’t stay after updating the settings. But, the “scsi0:0.ctkEnabled” line remains.

LEAVE A COMMENT

Proudly Sponsored By

GC On-Demand

Subscribe to the Blog

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Upcoming events:

Archives